Getting Started

Here’s how to get started with Cursive.

Download IntelliJ

First, if you haven’t already, download IntelliJ here. If you don’t have a licence for the Ultimate Edition, the free Community Edition is fine. IntelliJ is available for Windows, Mac OS X, and Linux. Cursive will work with IntelliJ versions 14, 14.1, 15, 2016.1 and the new 2016.2 EAP.

Plugin Selection

If you’re starting IntelliJ for the first time, it will ask you to select the plugins you’d like to use from the list of bundled plugins. It’s a good idea to disable plugins you know you’ll never use to improve startup time and memory use. If you change your mind later, you can always re-enable them in Settings→Plugins.

Coming from Eclipse?

If you’re used to using Eclipse, JetBrains have a migration guide. It’s fairly Java specific but there’s some useful information there relevant to Cursive too, as well as basic IntelliJ terminology.

Removing La Clojure

If you already have La Clojure from JetBrains or the existing Leiningen plugin from Jan Thomä installed, you’ll need to uninstall them or they’ll conflict with Cursive and its Leiningen integration. Open the IntelliJ Settings→Plugins. Uninstall both plugins by selecting them and pressing the uninstall button () and then press Ok. Restart IntelliJ when it prompts you to.

Note: You must uninstall these plugins - disabling them is not sufficient.

Installing Cursive

If this is the first time you’ve started IntelliJ, you’ll see the welcome screen:

To install the plugin, open the plugins dialog from the Configure menu:

If you’ve been using IntelliJ previously, then open the plugins window from Settings→Plugins as normal.

Once in the plugins window, press “Browse Repositories…” and search for Cursive.

Install Cursive using the green install button, then close the Browse Repositories window and the Settings window. Restart IntelliJ when it prompts you to.

The first time you start IntelliJ with Cursive installed, you’ll be prompted for a licence. If you have a licence already, you can enter it using the “Enter licence” button. You can get a licence from our website by using the “Open website” button. If you want to try Cursive out, or are waiting for a licence you can use the “Evaluate for 30 days” option. You can always enter a licence at a later date using Help→Register Cursive…. If you don’t want to use Cursive, use the “Disable and restart” button.

Once you’ve chosen your option and accepted the licence conditions, you’ll be ready to get started!

Choosing to receive EAP (beta) builds

Cursive uses two separate channels for releases. Stable builds are released in the JetBrains plugin repository as normal, and IntelliJ will automatically prompt you to upgrade when new Cursive versions are available. However, in order to receive feedback about new features, generally we will release one or more Early Access Program (EAP, or beta) builds prior to releasing a stable one. If you’d like to try the latest and greatest features, and you’re willing to accept that they might not have had all the bugs worked out yet, you can opt in to receive these builds as well. When you first install Cursive you’ll be prompted to choose whether you’d like to receive EAP builds, but if you change your mind later you can always change the setting at Settings→Languages & Frameworks→Clojure→Check for EAP builds. After enabling this option, you can then go to Settings→Plugins→Browse Repositories… and press the Refresh button () and then search for “Cursive” to see if there are any EAP builds currently available.

IntelliJ Settings

IntelliJ is very configurable - you’ll find the general settings in IntelliJ IDEA→Preferences on OSX, or File→Settings on Windows or Linux. If you’re looking for something specific, try typing it into the search box above the left hand panel and IntelliJ will highlight any instances of settings with that name. All Cursive settings are searchable in this way.